Banshee
the secure PHP framework

Forum

Problem uploading mysql.sql with phpMyAdmin

chapchap70
16 June 2016, 06:34
I have successfully uploaded the banshee database numerous times with php5 and php7 but am not able to do so now with either. Before I (re)submit this as a bug to them, maybe someone can try to import a banshee mysql.sql to see if it can be duplicated and I didn't do something wrong?

The error I keep getting is the same as this old bug and maybe it resurfaced? https://sourceforge.net/p/phpmyadmin/bugs/4128/

Tried the mysql.sql files with v5.1, 5.2, and 5.3 with the same results. I am using phpMyAdmin v4.5.2

Thanks
Hugo Leisink
16 June 2016, 12:43
Have you tried using the Banshee setup module?
chapchap70
16 June 2016, 12:55
Yes. It gives me an error every time. I've always had to do it manually.
Hugo Leisink
16 June 2016, 23:01
What error?
chapchap70
16 June 2016, 23:54
Banshee setup
Enter The MYSQL root credentials ....

I click the Create database button.

The next step is to import the file database/mysql.sql into your database.

After I click the 'Import SQL' button, "Error while importing database tables." Appears in a tan rectangle.

Looking at myPhpAdmin, an empty database is loaded. Nothing appears different upon refresh after I click the Import SQL button.

chapchap70
17 June 2016, 00:22
When trying it manually from phpMyAdmin, the agenda table imports but no others and I get the error as described in my initial post.

If I remember right, there were about 66 tables. The only thing I can think of that I did differently is that I set up a different password in mysql. I was using the default with no password,
Hugo Leisink
17 June 2016, 00:35
Is the MySQL command client installed?
chapchap70
17 June 2016, 03:46
Yes it is and I am able to log in.

I am using XAMPP 5.6.21 The same thing happens in a working Banshee using XAMPP 7.0.4 with all the tables there. I tried using phpMyAdmin to import the mysql.sql into a database I named banshee2 and it did the same thing.
chapchap70
17 June 2016, 16:24
I think I confirmed that it is a phpMyAdmin error because I installed v4.6.2 and was able to import the mysql.sql that I named banshee2 and I see the same tables as the banshee I have working.

I don't know why I have never gotten the database uploaded by using the setup module though. I'll have to look into how to use the mysql command client. Sorry for the newbiness.
Hugo Leisink
18 June 2016, 23:07
No problem. Good to hear it's working.
James
27 January 2018, 19:25
I (as a relative newbie) had the same problem. I had to log into mysql as root and grant all privileges to my database user. I'm not sure if that's because I might have taken some more secure options for the mysql setup (because that was months ago), or if that's just a normal step that should be added to the install. I do know that I ran mysql_secure_installation as part of the mysql setup, so maybe that's why.